Podpora Debian 8 Jessie končí a upgráde na Stretch

Debian Stretch

Kráľ umrel, nech žije kráľ. V rýchlosti uvediem ako bezbolestne vykonať upgráde z Jessie na Stretch a ako bonus pridám, čo všetko sa vám pri tom poserie.

Podľa Long Term Supportu Debianu  sa nám bliži čas keď štafetu aktualizácií proti bezpečnostnému flákačstvu (nie len Intelu) preberá aktuálna Debian distribúcia – Stretch.

V prvom rade, neodporúčam použiť tento postup ak máte staršie distribúcie ako je Debian 8.x (Jessie). Teda 7, 6 či dokonca ešte staršie. Takmer určite by to skončilo fiaskom. Ale vyskúšať to môžete a potom mi dajte vedieť. Sám som zvedavý.

Čiže, verziu súčasného Debianu vyčmucháte na svojom stroji takto:

# cat /etc/debian_version
8.1

Pred totálnou prerábkou všetkého čo ste krvopotne vytvorili za tie posledné roky je viac ako žiadúce vykonať inštalácie posledných záplat a upgrejdov na aktuálnom systéme.

#apt-get update
#apt-get upgrade
#apt-get dist-upgrade

Skôr ako budete pokračovať

Slobodná komunita okolo Debianu sa rozhodla nepodporovať viac MySQL od Oraclu a miesto neho predvolili „slobodnejší“ MariaDB čo je defakto náhrada za MySQL. Inštalačný proces sa postará o „bezproblémový“ prechod vašich databáz a tabuliek z Oraclu do Márie ale viete ako to v tomto svete chodí, nikto vám nič negarantuje. Ak zignorujete moju dobre mienenú radu, spraviť si kompletnú zálohu všetkých databáz – bude to len vaša hlúposť.

#mysqldump -u root -p --all-databases > zaloha_DB.sql

Taktiež upozorňujem, že postup medzi verziami systému z nižšej na vyššiu bol vždy sprevádzaný aj drobnými problémami, ktoré tak nejak rozhasili funkčnosť služieb. Vyhraďte si preto na to čas keď váš server používa minumum užívateľov a najlepšie neskorú večernú hodinu keď je malá pravdepodobnosť, že vám bude niekto volať.

Upgráde z Jessie na Stretch

Teraz tá zábavnejšia časť.

Zeditujte súbor /etc/apt/sources.list a nahraďte všetky zmienky/slová „jessie“ na „stretch“. Je jedno či použijete nejaký svoj obľúbený editor a spravíte to ručne alebo celý proces zautomatizujete, napríjklad pomocou príkazu #sed . Výsledok by mal vypadať nejak takto:

deb http://ftp.sk.debian.org/debian/ stretch main
deb-src http://ftp.sk.debian.org/debian/ stretch main

deb http://security.debian.org/ stretch/updates main contrib
deb-src http://security.debian.org/ stretch/updates main contrib

deb http://ftp.sk.debian.org/debian/ stretch-updates main contrib
deb-src http://ftp.sk.debian.org/debian/ stretch-updates main contrib

deb http://ftp.debian.org/debian stretch-backports main
deb http://httpredir.debian.org/debian/ stretch main contrib non-free

Po týchto úpravach je to už len o zopakovaní posledných updejtovacích úkonov. Pripravte sa, že to bude trvať o niečo dlhšie ako naposledy. Teda opäť:

#apt-get update 
#apt-get upgrade 
#apt-get dist-upgrade

Po chvíľke trpnutia, určite odporúčam reštart celého systému. No a potom, keď systém nabehne?

Veci, ktoré sa určite možno poserú

Uvediem len tie, ktoré sa pokazili mne. Váš prípad to nemusí vôbec byť. Ale v prípade, že bude možno tu nájdete odpovede. Paradoxne, prechod MySQL=>MariaDB prebehol bez problémov. Väčšina vecí bola spôsobená ponechaním pôvodného konfiguračného súboru, ktorý už zmenil svoju štruktúru a niektoré parametre. Samozrejme vyjadriť sa môžem len k službám, ktoré sám používam. K ostatným sa vyjadriť neviem.

  • isc-dhcp-server
    Začal v /etc/defaults/isc-dhcp-server vyžadovať značenie „interfejsov“ verziou IP protokolu na ktorom má server načúvať. T.z., že parameter INTERFACES sa zmenil na INTERFACESv4 a INTERFACESv6 podľa toho či používate IPv4 alebo 6.
  • dovecot
    Parameter, ssl_protocols v /etc/dovecot/dovecot.conf už neobsahuje SSLv2 od verzie OpenSSL v.1.1 a uvedenie tohto parametra považuje za chybu.
  • fail2ban
    Moje najväčšie sklamanie! Akosika razantne sa v Stretchi rozdelila celá štruktúra konfiguráku. Samozrejme, že je teraz prehľadnejšia ale akosika to kolidovalo s verziou ktorú som mal ešte od Debiana Wheezyho.  Najrýchlejšia cesta ako to napraviť nakoniec ostala #apt-get purge fail2ban; #apt-get install fail2ban  a všetko ponastavovať znova.
  • fail2ban, part II
    Failed to execute ban jail ‚postfix-sasl‘ action ‚iptables-multiport‘ info – súbor /etc/fail2ban/jail.conf sa odkazuje na službu – imap3 ktorá v /etc/services neexistuje a nie je definovaný port na ktorom služba stojí. Buď teda doplniť do services alebo zmazať zmienku z jail.conf.
  • opendmarc
    Tak tu po pravde doteraz neviem prečo ale nedarí sa mi ho spustiť. Resp. on sa aj spustí ale na určenom sockete akosika nie je a tvári sa akoby ani nebežal. Dočasne som ho vyradil úplne a určite sa k nemu ešte plánujem vrátiť.
  • clamav, freshclam
    Spustenie freshclamu vyriešilo „paniku“, ktorú upgrade Clamavu spôsobil 🙂
  • SSHD /etc/ssh/sshd.conf
    Deprecated options
    KeyRegenerationInterval, RSAAuthentication, RhostsRSAAuthentication, ServerKeyBits

Migrácia Apache, PHP, Samby a ďalších, menších služieb prebehla bez problémov. Za čo komunite okolo Debianu touto cestou ďakujem. 🙂

One Comment on “Podpora Debian 8 Jessie končí a upgráde na Stretch”

Pridaj komentár

Vaša e-mailová adresa nebude zverejnená. Vyžadované polia sú označené *

Táto webová stránka používa Akismet na redukciu spamu. Získajte viac informácií o tom, ako sú vaše údaje z komentárov spracovávané.